Windows Home Server Connection Lost Troubleshooting

I’ve had a problem recently where clients would fail abruptly.  These were clients that had been backing up reliably for months so it seemed a little strange to me.  The error in my Event Viewer was:

 

Backup of volume C: to SERVER failed: Microsoft.HomeServer.Backup.Protocol.ProtocolException: Client / Server connection lost

 

The error points to a networking problem.  I researched it a bit and found recommendations to download the WHS Toolkit.  So I downloaded it and ran it.  It told me that my connector software didn’t match my server version.  So I deleted my connector software and re-installed it from the server.  I tried to run a backup again and it failed again at about 70%.  So I ran the troubleshooter again and it again told me that I had a version mismatch.

 

The interesting thing is that my home server was almost full.  I started the backup and it told me that it only had 139GB left in space.   Then it counted down as the backup continued until it told me that it only had 90GB of space left and then the backup failed again.  I checked the Event Viewer and the error was still the same, some sort of connection loss between the server and the client.  I ran the WHS Toolkit again and it again told me that I had a version mismatch between my client and server.

 

On a whim I purged 200GB of data from the server, ran the backup again.  It succeeded.  If you run into this problem and your home server is tight on space, I’d suggest offloading some data to an external drive or adding another drive and trying again.  The log output is misleading.  This is not a connection problem, you’re just out of space.